请选择 进入手机版 | 继续访问电脑版

衡水摄影网

 找回密码
 立即注册
查看: 837|回复: 1

magento 2.1.3 2.1.6 安装错误 和 如何重新安装Magento 2

[复制链接]
发表于 2017-5-15 10:19:34 | 显示全部楼层 |阅读模式
本帖最后由 老镜头 于 2017-5-15 16:18 编辑

重新安装之前删除下面文件夹

rm -rf var/cache
rm -rf var/generation
rm -rf app/etc/config.php
rm -rf app/etc/env.php



下载了最新的magento2.1.3安装到第一步出现报错:
加代码注意上面的 , 号

PHP Version Check

Your PHP version is . The required PHP version is . Hide detail

Download and install PHP from www.php.net using this PHP Documentation.

For additional assistance, contact your hosting provider.



PHP Settings Check *

Your PHP settings are correct.




Cannot determine required PHP extensions: Warning: is_dir(): open_basedir restriction in effect. File(/etc/pki/tls/certs) is not within the allowed path(s): (/home/sanikala/:/tmp:/var/tmp:/usr/local/lib/php/:/usr/local/php56/lib/php/) in /home/sanikala/domains/sanikala.com/public_html/vendor/composer/composer/src/Composer/Util/RemoteFilesystem.php on line 914

这个问题最模板检查排除之后,原来是magento2默认安装是必须存在SSL的,但是我们默认是未有ssl在,所以可以在文件屏蔽该检测。

找到文件composer.json

在23行,找到

"config": {
        "use-include-path": true
    },

修改成

"config": {
        "use-include-path": true,
         "disable-tls": true
    },
[/td][/tr]
[/table]
回复

使用道具 举报

 楼主| 发表于 2017-5-15 16:12:21 | 显示全部楼层
本帖最后由 老镜头 于 2017-5-15 16:15 编辑

安装完成后 后台左侧导航 图片不显示 前台CSS JS错乱

请看说明
http://newsmartwave.net/magento2/
porto/documentation/
SSH中执行 下面代码 加载 CSS  JS ......
  • Step 1:  php bin/magento setup:static-content:deploy
  • Step 2:  php bin/magento indexer:reindex


123.jpg


回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|手机版|小黑屋|衡水摄影网

GMT+8, 2018-12-10 11:13 , Processed in 0.033045 second(s), 18 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表